What are browser requirements for using Ancestry Library Edition



To use Ancestry Library Edition you should have a browser that meets or exceeds the minimums listed below: