Minimum Browser Requirements for Historic Map Works Library Edition

 

What are the browser requirements for Historic Map Works™ Library Edition?

 
Historic Map Works™ Library Edition requires the use of browsers listed below:

Internet Explorer (IE) 5.5 or later
Firefox 2.0 or later