Browser requirements for Sanborn Maps

 
What are the minimum browser requirements for Digital Sanborn Maps?
 
To use Digital Sanborn Maps you should have a browser that meets or exceeds the minimums listed below:
  • Internet Explorer 6.0
  • Firefox 2.0