Browsers and operating systems requirements for Safari

 
Which browsers and operating systems are compatible with Safari?
 

Safari content is displayed in HTML format within your browser. Safari works with HTML 4.0-compliant browsers with cookies, JavaScript and pop-ups enabled.

Please click here for a list of supported browsers and operating systems:


The plugins required to view Video based content are:

Flash Player 9 or higher
Quicktime 7.2 or higher
Windows Media Player 11 or higher in Internet Explorer ONLY.