Plugins required for HeritageQuest Online

What are the plugins required for HeritageQuest® Online?

In order to view or download images of documents in PDF format, you will need to have the Adobe® Reader plugin version 5.0 or higher installed.

If you do not already have the Reader installed, you can download it from the Adobe site.