What are the system requirements for Alexander Street Database?



What are the system requirements for Alexander Street Database?

This product is optimized to operate with the following browsers and plugins:

Note: Adobe does not offer the plugin required to view .PDF files in a web browser for Firefox. Adobe Reader plugin is only available for Safari.

However, users will be able to download .PDF files to their computer using Firefox.

For best performance, the latest version of Adobe Reader  is recommended in order to view PDFs.

Audio and video resources are accessible with Adobe Flash Player 9 or higher.